Import Mapping Tool

Understanding the Import Mapping Tool

The Import Mapping Tool is a helpful feature that lets you import information into Sellercloud from files that are not in the standard Sellercloud format. Importing information is done in four easy steps:

  1. Access the Mapping Tool
  2. Create a mapping profile
  3. Access the Mapping Profile Details to map your file headers to Sellercloud columns
  4. Import your information
You can automate imports by creating a scheduled task.
The steps to create a mapping profile and import your information differ based on the interface.

Step #1 – Accessing the Import Mapping Tool

You can easily access the Import Mapping Tool right from your Settings tab. Once you access the the page, you can perform a variety of actions, such as:

  • Creating a profile
  • Deleting a profile
  • Exporting a profile
  • Uploading a profile
  • Downloading a sample template

Learn how to access the Import Mapping Tool and perform some of these actions in each interface by clicking the appropriate accordion below.

Alpha

To access the Import Mapping Tool in Alpha, follow these steps:

  • Go to Settings > Import Mapping Tool.

alpha import mapping tool

From the Import Mapping Tools Manage page, you can also perform a variety of different actions to your preexisting mapping tools. You can:

  • Create a profile
  • Delete a profile: Select the profile you want to delete> Go to the Action menu > Select Delete.
  • Export a profile: Select the profile you want to delete> Go to the Action menu > Select Export.
  • Upload a profile: Click Select File > Choose your file > Upload Profile(s) to upload your profiles.
  • Download a sample template: Click Download Sample.

Delta

To access the Import Mapping Tool in Delta, follow these steps:

  • Go to Settings > Mapping Tools > Manage Import Mapping Profiles.

import mapping tool

From the Import Mapping Tools Manage page, you can also perform a variety of different actions to your preexisting mapping tools. You can:

  • Create a profile
  • Delete a profile: Select the profile you want to delete> Go to the Action icon > Select Delete.
  • Export a profile: Select the profile you want to export > Go to the Action icon > Select Export.
  • Upload a profile: Go the Action icon > Drag and drop a file, or click to select your file >  Upload.
  • Download a sample template: Go the Action icon > Click Upload > Click Download Template.


Step #2 – Creating a mapping profile

Before you can begin creating a profile, you should learn how to access the Import Mapping Tool. A mapping profile is simply a profile that helps Sellercloud understand how you want to import information. You can create multiple profiles, like:

  • Orders profile
  • Tracking profile
  • Product profile
  • Inventory profile
  • Warehouse Inventory profile
  • Vendor Product profile
  • Customer profile

After you create a new profile, you can visit the Mapping Profile Details page to begin mapping your columns.

Alpha

Click on the appropriate profile type to learn more.

Order profiles
Order profile
An orders profile lets you import order related information into Sellercloud using files that are not in the Sellercloud format.To create an orders profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Orders from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
    • Check Order is Paid, if applicable.
    • Check Order is Authorized, if applicable.
  4. Select an Order Source for the orders imported under the profile. For example, Local Store, Website, or Wholesale.
  5. Select Company and Warehouse from the dropdown menu. Choose the warehouse that these orders should ship from.
  6. Leave the Vendor dropdown blank.
  7. Click Choose File and upload the file. If applicable, check File contain headers.
  8. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Tracking profiles
Tracking profiles
A tracking profile lets you import an order tracking file into Sellercloud when the file is not in Sellercloud format.To create a tracking profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Tracking as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
    • Check Order is Paid, if applicable.
    • Check Do not change shipped orders, if applicable.
  4. Select the Warehouse and Vendor.
  5. Click Choose File and upload the file. If applicable, check File contain headers.
  6. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Product profiles
Product profiles
A product profile lets you create new products and update existing product information by importing a file that is not in Sellercloud format.To create a product profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Product as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company, Warehouse, and Vendor. If applicable, check Only Update Existing Products.
  5. Click Choose File and upload the file. If applicable, check File contains headers.
  6. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Inventory profiles

Inventory profiles

By default, the inventory import works with inventory ranges. This means that the exact inventory will not be on the product. Rather, it will set the inventory to the lowest value within the range.

  • Ex: If the range is 10-20 and the product’s inventory on file is 17, then the quantity will be set to 10.

If you want to update the exact quantity, see the setting below Step 9.

Creating an inventory profile lets you import a file, that is not in Sellercloud format, to update the inventory quantities of products. This mapping tool will set the inventory for all the SKUs in your profile in the warehouse you select. With the mapping tool, you can update the following product attributes:

To create an inventory profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Inventory from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company.
  5. Select the Warehouse that your inventory will go under in the whole profile.
  6. Select Vendor.
  7. If applicable, check Zero Out Inventory If SKU Not Found In Inventory Feed.
    • Zero Out Inventory If SKU Not Found In Inventory Feed: If the SKU is not in the file, then that SKU’s inventory will be set to 0 for the warehouse that you selected.
  8. If applicable, enter the floor quantity under which it is considered to be zero.
    • Consider Qty below as Zero: All products with quantity below the specified amount will be considered as zero quantity. For example, if you set this to 10, then all inventory values below 10 will be considered 0.
  9. If applicable, enter data into Import static inventory upto.
    • Import static inventory upto: Imports static inventory up to a certain value with exact quantities entered in the file and then continues with ranges for inventory over this value. View the ranges. (You can also view ranges on the Mapping Profile Details page.)
      • Example: If the static inventory up to is 50 for instance, then all inventory up to 50 will be imported as entered in the file. Then, from 50 above it will look at the range.
  10. Choose the file template to import from your PC.
  11. Check File contains headers if applicable.
  12. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Warehouse inventory profiles
Warehouse inventory profiles
Creating a warehouse inventory profile lets you lets you import a file, that is not in Sellercloud format, to update the inventory quantities of products. This profile allows you to assign the warehouse per product and update multiple inventories of multiple warehouses. With the mapping tool, you can update the following product attributes:

To create a warehouse inventory profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  3. Select Warehouse Inventory as the Import Type.
  4. Select the Company for which the profile will be used.
  5. Select Vendor.
  6. Click Choose File > Upload your file. If applicable, check File contain headers.
  7. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Vendor product profiles
Vendor product profiles
Creating a vendor product profile lets you update product information for a particular vendor by importing files that are not in Sellercloud format.To create a vendor product profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Vendor Product as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company, Warehouse, and Vendor.
  5. Click Choose File and upload the file.
  6. If applicable, check File contains headers.
  7. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Customer profiles
Customer profile
Creating a customer profile lets you update customer information by importing a file that is not in standard Sellercloud format.To create a customers profile in Alpha, follow these steps:

  1. Go to Settings > Import Mapping Tool > Click Add New Mapping.
  2. Select Customers as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select your Company.
  5. Click Choose File and upload your file. If applicable, check File contains headers.
  6. Click Save Profile. The page will automatically refresh to you Mapping Profile Details page, where you can begin to map your columns.

Delta

Click on the appropriate profile type to learn more.

Order profiles
Order profiles
An orders profile lets you import order related information into Sellercloud using files that are not in the Sellercloud format.To create an orders profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Orders from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
    • Check Order is Paid, if applicable.
    • Check Order is Authorized, if applicable.
  4. Select a Channel for the orders imported under the profile. For example, Local Store, Website, or Wholesale.
  5. Select Company and Warehouse from the dropdown menu. Choose the warehouse that these orders should ship from.
  6. Leave the Vendor dropdown blank.
  7. Select your Template File.
  8. Check the File contains headers box if the file contains headers.
  9. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Tracking profiles
Tracking profiles
A tracking profile lets you import an order tracking file into Sellercloud when the file is not in Sellercloud format.To create a tracking profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Tracking from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
    • Check Order is Paid, if applicable.
    • Check Do Not Change Shipped Orders, if applicable.
  4. Select your Warehouse and Vendor.
  5. Upload your Template File. If applicable, check File contain headers.
  6. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Product profiles
Product profiles
A product profile lets you create new products and update existing product information by importing a file that is not in Sellercloud format.To create a product profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles> Go to the Action icon > Click Create.
  2. Select Product from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company, Warehouse, and Vendor. If applicable, check Only Update Existing Products.
  5. Upload your Template File. If applicable, check File contain headers.
  6. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Inventory profiles

Inventory profiles

By default, the inventory import works with inventory ranges. This means that the exact inventory will not be on the product. Rather, it will set the inventory to the lowest value within the range.

  • Ex: If the range is 10-20 and the product’s inventory on file is 17, then the quantity will be set to 10.

If you want to update the exact quantity, see the setting below Step 9.

Creating an inventory profile lets you import a file, that is not in Sellercloud format, to update the inventory quantities of products. This mapping tool will set the inventory for all the SKUs in your profile in the warehouse you select. With the mapping tool, you can update the following product attributes:

To create an inventory profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Inventory from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company.
  5. Select the Warehouse that your inventory will go under in the whole profile.
  6. Select Vendor.
  7. If applicable, check Zero Out Inventory If SKU Not Found In Inventory Feed.
    • Zero Out Inventory If SKU Not Found In Inventory Feed: If the SKU is not in the file, then that SKU’s inventory will be set to 0 for the warehouse that you selected.
  8. If applicable, enter the floor quantity under which it is considered to be zero.
    • Consider Qty below as Zero: All products with quantity below the specified amount will be considered as zero quantity. For example, if you set this to 10, then all inventory values below 10 will be considered 0.
  9. If applicable, enter data into Import static inventory upto.
    • Import static inventory upto: Imports static inventory up to a certain value with exact quantities entered in the file and then continues with ranges for inventory over this value.
      • Example: If the static inventory up to is 50 for instance, then all inventory up to 50 will be imported as entered in the file. Then, from 50 above it will look at the range.
  10. Upload your Template File. If applicable, check File contain headers.
  11. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Warehouse inventory profiles
Warehouse inventory profiles
Creating a warehouse inventory profile lets you lets you import a file, that is not in Sellercloud format, to update the inventory quantities of products. This profile allows you to assign the warehouse per product and update multiple inventories of multiple warehouses. With the mapping tool, you can update the following product attributes:

To create an inventory warehouse profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Warehouse Inventory as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select the Company for which the profile will be used.
  5. Select Vendor.
  6. Upload your Template File. If applicable, check File contain headers.
  7. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Vendor product profiles
Vendor product profile
Creating a vendor product profile lets you update product information for a particular vendor by importing files that are not in Sellercloud format.To create a vendor product profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Vendor Product as the Import Type.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company, Warehouse, and Vendor.
  5. Upload your Template File. If applicable, check File contain headers.
  6. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.

Customer profiles
Customer profile
To create a customer profile in Delta, follow these steps:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles > Go to the Action icon > Click Create.
  2. Select Customer from the Import Type dropdown menu.
  3. Enter Profile Name. If there are rows in the file that need to be skipped, enter the amount starting from the top in the Skip First Rows field.
  4. Select Company from the dropdown menu.
  5. Upload your Template File. If applicable, check File contain headers.
  6. Click Create. A Mapping Profile Details page will be created for you. From there, you can map your columns.


Step #3 – Accessing the Mapping Profile Details page

It is important to note that the Mapping Profile Detail pages are not the same as your Order Details or Product Details page.

Creating a profile automatically generates a Mapping Profile Details page. This page lets you view information and perform actions related to a specific profile. Some actions and information on the Mapping Profile Details page overlap, but there are a few differences between the profile types.
import mapping tool delta
Show me a sample page in Alpha.

To access the Mapping Profile Details page:

Alpha

To access the Mapping Profile Details page in Alpha:

  1. Go to Settings > Import Mapping Tool.
  2. Search for your profile > Click Profile ID.

Delta

To access the Mapping Profile Details page in Delta:

  1. Go to Settings > Mapping Tools > Manage Import Mapping Profiles.
  2. Search for your profile > Click Profile ID.

On certain Mapping Profile Details pages, you can also edit and view Shipping Method Mapping from your Toolbox in Delta. You can access this in Alpha by simply scrolling down your Mapping Profile Details page.

Mapping columns

The Mapping Profile Details page is where you can begin mapping your columns. Column mapping refers to taking the headers from your file and “mapping” them to Sellercloud headers. When you access the Mapping Profile Details page, you will see three columns:

  • Sellercloud Column: The column in Sellercloud (not exactly named).
  • Customer Column: The column headers from your file.
  • Custom Value: If you want a static value to be imported for one of the fields (for example, the Order_Email should always be the same here), choose _CUSTOM_VALUE_REQUIRED_ from the Customer Column dropdown, and then enter your static data into the Custom Value column.

import mapping tool delta
Show me a sample in Alpha
.

Some order related fields export data into digits. Click to view those fields.

Some order related mapped fields export data into digits. The table below explains those fields. These are the same in both interfaces.

FIELD DIGITS
bvc_Order.PaymentStatus
  • NoPayment = 10
  • Authorized = 20
  • Charged = 30
  • Uncleared = 40
  • PartiallyRefund = 50
  • FullRefund = 60
  • PartialPayment = 70
  • eBayPaid = 80
  • PaymentError = 99
bvc_Order.StatusCode
  • Canceled = -1
  • ShippingCart = 1
  • InProcess = 2
  • Completed = 3
  • ProblemOrder = 100
  • OnHold = 200
  • Quote = 300
  • Void = 999
bvc_Order.PickingStatus
  • None = 0
  • Partially_Picked = 1
  • Fully_Picked = 2
  • Over_Picked = 3
bvc_OrderPayment.PaymentStatus
  • Cleared = 0
  • NotCleared = 1
  • Unknown = 2
bvc_OrderPayment.PaymentType
  • Information = 1
  • Payment = 2
  • Refund = 3

When using the Import Mapping Tool, you may wonder which columns to use. It is helpful to note that:

  • You can find any order related column you’re looking for by viewing the Order Change Log (known as History in Sellercloud’s Alpha interface). To access your Order Change Log:
  • You can find any product related column by altering the product information you want to know the column name for, and then viewing the column associated with that change in the Change Log (known as History in Sellercloud’s Alpha interface). To access your Product Change Log:

To begin mapping your columns:

Alpha

To map your columns in Alpha:

  1. Go to the Mapping Profile Details page and scroll to the column mapping.
  2. Input your information > Save Mapping.

Delta

To map your columns in Delta:

  1. Go to the Mapping Profile Details page > Click Edit.
  2. Go to the Column Mapping panel > Input your information > Save.

You can reference a product field using a placeholder. For example, although the UPC is not part of the order table, you can export the UPC of the ordered item by choosing Custom_Value_Required and in custom value format a placeholder like this: #?product.UPC?#.
With a multi-item order, you can map all items in the order by using a placeholder. Choose Custom_Value_Required and in custom value, enter placeholder #?ROW_COUNTER?#.

Step #4 – Importing your information

After you’ve created your profile and mapped your columns, it’s time to use your profile to upload information into Sellercloud. The steps to import information using your new profile are different depending on profile type and the interface you are using. Click the appropriate interface accordion to learn how to import each type of profile.

Alpha
Click on the appropriate profile type to learn more.

Order profiles
Orders profiles
To import information using an orders profile in Alpha:

  1. Go to Orders > Import Orders.
  2. Select Order Import Profile from the Channel dropdown menu.
  3. Select your mapping profile from the Order Import Profile dropdown menu.
  4. Click Choose File > Upload your file.
  5. Click Process Order to submit the import job.

Tracking profiles
Tracking profiles

To import information using a tracking profile in Alpha:

  1. Go to Orders > Import Tracking Info.
  2. Select Company.
  3. Click Choose File > Upload your file.
  4. Select your mapping profile from the Plugin dropdown menu.
  5. Click Import Tracking Details.

Product and Inventory profiles
Product and Inventory profiles

To import information using a product or inventory profile in Alpha:

  1. Go to Inventory > Import Product Info.
  2. Select Import Profile from the Select Plugin dropdown menu.
  3. Select your Import Profile from the Profile dropdown menu.
  4. Click Choose File and upload your file > Import Products Info.

Warehouse inventory profiles
Warehouse inventory profiles

To import information using a warehouse inventory profile in Alpha:

  1. Go to Inventory > Warehouse Inventory Import.
  2. Go to Import Inventory With Profile.
  3. Click Choose File and upload your file.
  4. Select your Import Profile from the Select Profile dropdown menu.
  5. Click Import Inventory via Profile.

Vendor product profiles
Vendor product profiles

To import information using a vendor product profile in Alpha:

  1. Go to Inventory > Import Product Info > Import Vendor SKU/Prices.
  2. Select Company and Profile from the dropdown menus.
  3. Click Choose File and upload your file.
  4. If you want, you can select a specific Job Schedule Time.
  5. Click Import Products/Prices.

Customer profiles
Customer profiles

To import information using a customer profile in Alpha:

  1. Go to Customers > Import Customers.
  2. Select and upload your file > Select your File Type.
  3. Select your mapping profile from the Import via Plugin dropdown list.
  4. Click Upload Customers.

Delta
Click on the appropriate profile type to learn more.

Order profiles
Order profiles
To import information using an orders profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Orders > Tools > Import Order Info.
  2. Select Import Orders via Profile > Select your Company and Profile (the profile you just created), and File > Import.

Tracking profiles
Tracking profiles

To import information using a tracking profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Orders > Tools > Import Order Info.
  2. Select Import Tracking via Profile > Select your Company and Profile (the profile you just created), and File > Import.

Product profiles
Product profiles

To import information using a product profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Catalog > Tools > Import Product Info.
  2. Select  Import Info via Plugin/Profile > Select your Company and Profile (the profile you just created) > Choose your File > Import.

Vendor product profiles
Vendor product profiles

To import information using a vendor product profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Purchasing Tools > Import Purchase Info.
  2. Select Import Vendor Price > Select your Company and Profile (the profile you just created) > Choose your File > Import.

Inventory and warehouse inventory profiles
Inventory and warehouse inventory profiles

To import information using an inventory or warehouse inventory profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Inventory Tools > Import Inventory Info.
  2. Click Import Inventory via Profile > Select your File and your newly created Profile from the dropdown menu > Import.

Customer profiles
Customer profiles

To import information using a customer profile in Delta:

  1. After you map your columns, you can import your information into Sellercloud using your new mapping profile by going to Customers > Tools > Import Customers Import Customer Info.
  2. Select your newly created profile from the Import Via Plugin dropdown menu > Select your File Type > Upload your File > Import.


Was this article helpful?

Related Articles